• Homepage
  • >
  • Blog
  • >
  • Acronis Backup & Recovery 11.X und Dienstfehler 1075

Acronis Backup & Recovery 11.X und Dienstfehler 1075

Seit Jahren favorisiere ich Acronis als Datensicherung meines Vertrauens – seit der Backup & Recovery 10-Version und speziell meinem Liebling vmProtect hat Acronis noch einen weiteren riesen Schritt in Sachen Sicherheit und Bedienbarkeit gemacht. Doch auch hier gibt es manchmal Aussetzer, denn wie erklärt man sich (oder dem Kunden), dass sowohl beim Windows 2008 R2- als auch beim 2012er Server (wobei letzterer offiziell noch nicht unterstützt wird, aber trotzdem läuft) nach Installation von Backup & Recovery 11 bzw. 11.5 der Dienst „Acronis Managed Machine Service“ seinen Start versagt und damit eine Anmeldung an der Konsole nicht möglich ist? Ein wenig Suchen hat auch hier zum Erfolg geführt, schauen wir uns aber erst einmal den Fehler an:

Beim Starten der Acronis Management Konsole (im vorliegenden Fall auf einem Server 2012 Essentials mit installierter Backup & Recovery 11.5 Build 32308) erscheint unerwartet und trotz „frischer“ Installation eine folgende Fehlermeldung (und ja, die Datei existiert!).

Beim Versuch, den Dienst dann manuell über die Diensteverwaltung zu starten, geht die Fehlermeldung ein wenig mehr ins Detail, können wir doch ohne Konsultieren der Acronis Knowledge Base (und selbst da manchmal nicht) die Ursache des Servers sonst schwer ausmachen.

Schauen wir uns nun also einmal die Abhängigkeiten des Acronis-Dienstes an, fördern wir folgendes zu Tage.

Wir sehen nun eine Abhängigkeit zum Acronis Scheduler2 Service und zur Windows-Verwaltungsinstrumentation. Letzterer stellt eine Schnittstelle (WMI) für den Zugriff auf Verwaltungsinformationen zu Betriebssystemen, Geräten, Anwendungen und Diensten bereit. Über WMI greifen in Windows die meisten Anwendungen auf Verwaltungsinformationen zu. Der Dienst darf deshalb auch nicht deaktiviert werden, da ansonsten etliche Anwendungen nicht mehr ordnungsgemäß funktionieren würden. Aber das wollen wir an der Stelle auch nicht, laufen doch beide genannten Dienste anstandslos.

Der Workaround sieht nun so aus, dass schlichtweg die Abhängigkeit zwischen dem Acronis Scheduler2 Service und der Windows-Verwaltungsinstrumentation gelöst werden muss, damit die Acronis-Konsole sich starten lässt. An dieser Stelle sei erwähnt, dass ich mit diesem Workaround das Problem definitiv behoben habe, ich allerdings nicht weiss, ob diese Lösung auch im Sinne des Softwareherstellers ist.

Andererseits fehlt mir auch eine Erklärung, warum auf zwei unterschiedlich und frisch installierten Testsystemen mit frisch installierten Acronis-Builds ein solch elementarer Fehler auftreten kann. Aber sei’s drum – wir starten nun als Administrator entweder die gute alte Command Shell („cmd“) oder – auf Windows 2012 Server – zunächst die PowerShell („powershell.exe“), um von dort aus per Eingabe von „cmd“ in die alte Command Shell zu gelangen.

Durch Eingabe des Befehls

sc config mms depend= „“

lösen wir nun die oben genannte Abhängigkeit auf. Wichtig ist das Leerzeichen zwischen dem „=“ und den beiden Gänsefüsschen!

Die Meldung „[SC] ChangeServiceConfig ERFOLG“ zeugt von eben diesem und lässt uns nun den Acronis Managed Machine Service und somit auch die Verwaltungskonsole starten.

  • facebook
  • googleplus
  • twitter
  • linkedin
  • linkedin
  • linkedin

Stolzer Familienvater. Digital Native und chronischer Device-Switcher. Multimedia-Freak. UK-Fan, auch mit Brexit. Blogger mit stets zu wenig Zeit. Hobbyphilosoph. Musik-Enthusiast. Querdenker. Zyniker. Hauptberuflicher IT-Consultant- & Vertriebler. Auch zu finden bei XING. Dieser Artikel hat einen Job oder zumindest Euren Seelenfrieden gerettet und gegebenfalls sogar für Kurzweil gesorgt? Die PayPal-Kaffeekasse freut sich - dankeschön!

  • facebook
  • twitter
  • googleplus
  • linkedIn
  • instagram
  • telegram

23 Kommentare

  1. Danke!!!!
    Warum kann das der Hersteller nicht?

    • Gerne! Manchmal ist es so, dass man sich aus der Not eher zu helfen weiss und so eher eine Lösung findet! Mittlerweile handhabe ich das auch so, einfachere Fehler erstmal über die Acronis Knowledgebase zu suchen und die Support-Karte in der Hinterhand zu haben – wobei Du (bzw. der Kunde) das mit dem AAP ja eh mitkauf(s)t! Dennoch sind es manchmal gerade Fehler, die es auf frisch installierten Systemen einfach nicht geben müsste und bis man die mal dem Support erklärt hat, vergeht manchmal Zeit – das habe ich aber schon (fast) überall erlebt!

  2. Super Danke, probiere ich auch gleich mal.

  3. Klappt bei mir nicht, in PowerShell bekomme ich den Fehler
    „Set-Content : Es wurde kein Positionsparameter gefunden, der das Argument „depend=“ akzeptiert.
    In Zeile:1 Zeichen:1″

    In der Command Shell führt er den befehl aus, aber ich kann den Dienst und die Konsole immer noch nicht starten.

    • Klappt doch. Du musst nur innerhalb der Powershell via Eingabe von „cmd“ in die DOS-Shell / Eingabeaufforderung wechseln, wie es im Artikel beschrieben ist – Zitat:

      … zunächst die PowerShell (“powershell.exe”), um von dort aus per Eingabe von “cmd” in die alte Command Shell zu gelangen.

      Die Powershell allein kann diesen Befehl nicht interpretieren. Alternativ auch direkt die Eingabeaufforderung als Administrator starten und dann den

      sc config mms depend= „“

      Befehl eingeben, wobei unbedingt auf das erste Leerzeichen hinter dem „=“ zu achten ist, ansonsten kommt ein „OpenService FEHLER 5 – Zugriff verweigert“-Error!

  4. Danke für den Tipp. Bin auch zuerst auf der Acronis KB nicht fündig geworden. Klappt nun wunderbar.

  5. … traurig, dass Acronis das Problem in 3 Monaten noch nicht gefixt hat …

    auf jeden Fall herzlichsten Dank für die Lösung!

  6. Bei mir wird Fehler nach wie vor nicht behoben.
    CMD führt den Befehl erfolgreich aus, hebt die Abhängigkeit auf, Fehlermeldung beim Startversuch von Acronis sowie dem Dienst bleiben aber die Selben.

    Windows Server 2012 Neuinstallation

    • Mittlerweile habe ich dieses Phänomen auch bei diversen Windows 8-Installationen (jeweils 32- und 64 Bit) festgestellt – Befehl wird ausgeführt, Effekt bleibt aber der gleiche. Bisher leider ohne Lösungsweg – hier müssen wir wohl zähneknirschend auf das offizielle Release warten. Scheint aber auch am Horizont zu stehen, zumindest Acronis Recovery for MS SQL Server erscheint ja demnächst mit offizieller Windows 8 / Server 2012-Unterstützung. Hoffen wir, dass die anderen Editionen in dem Schweif dieses Releases mitziehen :-/ !

      • Behelfslösung:

        In Registrierungsdatenbank

        HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesMMS

        den Schlüssel „protected storage“ löschen.
        Dann startet Acronis problemlos und führt auch Backups durch. Leider tritt noch ein Fehler in der „Laufwerksverwaltung“ von Acronis auf. Vielleicht bekommst du den ja selbst gerade gezogen.

        Gruß

        • Danke für den Hinweis, allmählich nähern wir uns ja gemeinsam dem vollständigen Workaround 😉 ! Unter Windows 8 sehe ich diesen Schlüssel allerdings nicht, unter Server 2012 habe ich ihn gefunden – verstehe einer da Acronis!

  7. Hi Oliver,

    der Workaround funktioniert bei meinem Win Srvr. 2012 nicht =/.
    Ist auch nicht weiter wild, vorerst zumindest. Hälst du uns auf deinem Blog diesbzgl. aktuell?
    merci

    ben

    • Das ist schade, habe ich aber bei völlig unterschiedlichen Servervarianten mittlerweile nachvollziehen können. Selbstverständlich halte ich Euch auf diesem Blog aktuell, was dieses Thema angeht, denn nach Jahren der Treue zu Acronis (speziell als Systemberater) muss ich mangels eines halben Jahres ohne Unterstützung für aktuelle Server- und Clientsysteme wirklich auch langsam mal anschauen, wieder über den Tellerrand (Symantec?) zu schauen – möchte ich eigentlich nicht, aber allmählich drängt die Zeit. Hoffen wir, dass Acronis (wie in einigen Quellen angekündigt) bald mal ein entsprechendes Update anbietet, sonst sehe ich schwarz! Denn ist der Ruf erst ruiniert…

  8. Hi Oliver,
    Danke für die Hilfe. Schlage mich seit Stunden mit der installation rum.
    Jetzt läuft alles wunderbar.

    Gruß Michi

  9. Hallo, kann es sein dass der Dienst bei vmProtect (v8) „vmms“ heisst?

    • Problem trat nach Update innerhalb der 8er Version „vmProtect (R)“ auf.
      Nach Befehl siehe oben (aber als Dienstname „vmms“) und nachfolgendem Neustart ist das Problem offenbar behoben.

      Vielen Dank, auch für die ganze Website

      • Danke für das Lob, das Problem muss ich beizeiten mal nachvollziehen. Würde mich aber echt wundern, wenn dieses (bei den Servervarianten mittlerweile behobenes) Chaos nun auch bei der bislang absolut verlässlichen vmProtect 8 auftreten würde. Man lernt aber nie aus 😉 !

    • Bei vmProtect sollte dieser Fehler erst gar nicht auftreten – im Normalfall läuft die Appliance für vmProtect ja unabhängig von den einzelnen Servern. Zumindest ist das die sauberste Variante, vmProtect zu nutzen. Der hier aufgeführte Fehler war bis zum letzten Build nur ein Bestandteil der Backup & Recovery 11.5 Server-Varianten!

  10. Der beste Tipp zu dieser Katastrophe von Backup Programm, den ich bisher gefunden habe. Seitdem schnurrt der SBS 2011 Essential wieder eine Eins. Und die Startzeit hat sich mehr als halbiert. Warum bekommt der Hersteller das nicht hin?

    Kompliment für diesen Workaround!!!!!!

  11. mit diesem supertip kann ich endlich diese acronis software nutzen

    ist ja unglaublich was acronis da abliefert

    der acronis support konnte nach endlosen telefonaten das problem nicht lösen

    schlussendlich hiess es lapidar, dass man windows Server OEM versionen nicht supporten … na bravo acronis..

    einfach unglaublich …

    und das bei diesen software preisen

    • Danke für das Feedback! Leider ist man in Sachen Support oft von Einzelnen abhängig – ähnliche Aussagen (Treiberproblem bei Lenovo, als Windows 8 schon vier Monate auf dem Markt war – Aussage Supportmitarbeiter: „Das ist ja noch so neu, da gibt es noch kaum Support für. Warten Sie bitte ein paar Monate!“) kenne ich auch von anderen Herstellern. Mit Acronis haben Kunden von mir überwiegend allerdings nur gute Erfahrungen gemacht, auch wenn gerade dieser beschriebene Fehler so bisher der grösste Bock war, der mir mit Acronis in den letzten Jahren über den Weg gelaufen ist.

      Die Aussage, Windows Server OEM-Versionen nicht zu supporten, lässt in erster Linie auf einen dieser oben bezeichneten Fälle schliessen, die einfach keine Lust haben, zahlende Kunden bei einem nicht unbedingt unkritischen Thema entsprechend zu supporten. Aber wie gesagt: Ausnahmen bestätigen leider die (oft so gute) Regel! Ich könnte auch von CA Geschichten erzählen, wo ein ArcServe plötzlich aufhörte, eine virtuelle Farm zu sichern und die Lösung letztendlich darin bestand, ArcServe durch Acronis vmProtect 9 abzulösen. Für CA war irgendetwas an der Kundenumgebung nicht in Ordnung – wie das aber von jetzt auf gleich eintreten konnte, wollte niemand genauer prüfen – angeblich wären die ESXi-Server schuld. Resultat: ArcServe raus, vmProtect rein – Kunde zufrieden.

      Was die Preisstruktur angeht, ist Acronis noch sehr gut unterwegs – Mitbewerber wie eben CA oder Symantec lassen Dich da deutlich mehr bluten 😉 !

Kommentar verfassen